Symptoms
Unexpectedly denied access to cluster or pipeline, when in the appropriate role.
Cause
You are not in a team with access. Roles are not the same as teams.
Solution
- Ensure you are on the right Team.
- To add a user to a team:
- With an Administrative user, go to Account Settings
- Click "Teams" and select the appropriate team
- In the upper-right corner, select "Invite to Team"
- Type in the team member's username and add them.
- Ensure your team has the correct permissions.
- To change permissions:
- With an Administrative user, go to Account Settings
- Click "Permissions"
- You may now modify your teams to your needs
Notes Teams are what controls your access to pipelines and clusters. For example, if you are listed as a “user” for your role, but you’re not in the “users” team, you won’t have access to the pipelines available only to users.
- Roles refer to access to the billing, integrations, and team-managing views. This should be limited to only those that need them.
- Teams refer to what access you have in terms of pipelines and clusters.